Segmentation Fault/Having Trouble Running Polyhedron_3 Demo

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Segmentation Fault/Having Trouble Running Polyhedron_3 Demo

sfucci
Using a Mac, trying to run Polyhedron_3.exe with wine, 

Enable scripts. 
002d:fixme:wgl:set_pixel_format DC for window 0x10062 of other process: not
implemented 
002d:fixme:win:EnumDisplayDevicesW ((null),0,0x22dfd8,0x00000000), stub! 
002d:fixme:wgl:set_pixel_format DC for window 0x30066 of other process: not
implemented 
002d:fixme:wgl:set_pixel_format DC for window 0x40066 of other process: not
implemented 
002d:fixme:wgl:set_pixel_format DC for window 0x50066 of other process: not
implemented 
Execution of script ":/cgal/Polyhedron_3/javascript/lib.js" 
002d:fixme:wgl:set_pixel_format DC for window 0x60066 of other process: not
implemented 
In CGAL_handle_signal, Program received signal SIGSEGV: Segmentation
Fault.wc132-dhcp-137:polyhedron_3 sonya1$ 


Not sure what to do here, or if anyone else has experienced this. Thanks! 



--
Sent from: http://cgal-discuss.949826.n4.nabble.com/

--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://sympa.inria.fr/sympa/info/cgal-discuss


Reply | Threaded
Open this post in threaded view
|

Re: Segmentation Fault/Having Trouble Running Polyhedron_3 Demo

Sebastien Loriot (GeometryFactory)
 From the message you're showing, it seems that some opengl part are not
implemented in wine. I guess you should try to compile the CGAL demo
yourself and target MacOs natively.

Sebastien.

On 5/4/19 7:03 PM, sfucci wrote:

> Using a Mac, trying to run Polyhedron_3.exe with wine,
>
> Enable scripts.
> 002d:fixme:wgl:set_pixel_format DC for window 0x10062 of other process: not
> implemented
> 002d:fixme:win:EnumDisplayDevicesW ((null),0,0x22dfd8,0x00000000), stub!
> 002d:fixme:wgl:set_pixel_format DC for window 0x30066 of other process: not
> implemented
> 002d:fixme:wgl:set_pixel_format DC for window 0x40066 of other process: not
> implemented
> 002d:fixme:wgl:set_pixel_format DC for window 0x50066 of other process: not
> implemented
> Execution of script ":/cgal/Polyhedron_3/javascript/lib.js"
> 002d:fixme:wgl:set_pixel_format DC for window 0x60066 of other process: not
> implemented
> In CGAL_handle_signal, Program received signal SIGSEGV: Segmentation
> Fault.wc132-dhcp-137:polyhedron_3 sonya1$
>
>
> Not sure what to do here, or if anyone else has experienced this. Thanks!
>
>
>
> --
> Sent from: http://cgal-discuss.949826.n4.nabble.com/
>

--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://sympa.inria.fr/sympa/info/cgal-discuss