Opengl with cgal 3.3.1 on Mac OS X Leopard

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Opengl with cgal 3.3.1 on Mac OS X Leopard

scpeters
Hi,

I've just finished building CGAL 3.3.1 on Mac OS X Leopard 10.5.2.  In  
the default build, there was a linking error for the opengl  
libraries.  Specifically, it says:
ld: cycle in dylib re-exports with /usr/X11R6/lib/libGL.dylib
collect2: ld returned 1 exit status

This error is discussed on the apple developer website linked to  
below.  It can be circumvented by adding an LDflag.  I changed the  
config/support/S70-OPENGL file to include this LDflag and it fixed the  
problem.
http://developer.apple.com/qa/qa2007/qa1567.html

Should I send a patch or something?

Cheers,
Steve Peters

--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://lists-sop.inria.fr/wws/info/cgal-discuss
Reply | Threaded
Open this post in threaded view
|

Re: Opengl with cgal 3.3.1 on Mac OS X Leopard

scpeters
I sent that first email off a little too quick.  I had trouble  
compiling qt3 on Leopard as well, but I found the instructions on this  
page to be useful.  Basically apply a patch and it's good to go:
http://hans.fugal.net/blog/articles/2008/03/26/qcad-on-leopard

It is apparently enough to get qt to compile, though the demos don't  
seem to be running right.  It doesn't seem to accept mouse clicks or  
something.  Try at your own risk I guess.

Cheers,
Steve


On May 29, 2008, at 7:31 PM, Steven Peters wrote:

> Hi,
>
> I've just finished building CGAL 3.3.1 on Mac OS X Leopard 10.5.2.  
> In the default build, there was a linking error for the opengl  
> libraries.  Specifically, it says:
> ld: cycle in dylib re-exports with /usr/X11R6/lib/libGL.dylib
> collect2: ld returned 1 exit status
>
> This error is discussed on the apple developer website linked to  
> below.  It can be circumvented by adding an LDflag.  I changed the  
> config/support/S70-OPENGL file to include this LDflag and it fixed  
> the problem.
> http://developer.apple.com/qa/qa2007/qa1567.html
>
> Should I send a patch or something?
>
> Cheers,
> Steve Peters
>
> --
> You are currently subscribed to cgal-discuss.
> To unsubscribe or access the archives, go to
> https://lists-sop.inria.fr/wws/info/cgal-discuss

--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://lists-sop.inria.fr/wws/info/cgal-discuss
Reply | Threaded
Open this post in threaded view
|

Re: Opengl with cgal 3.3.1 on Mac OS X Leopard

Olivier Devillers
Steven Peters a écrit :
> I sent that first email off a little too quick.  I had trouble
> compiling qt3 on Leopard as well,


I install qt3-mac (using fink) and at least the Triangulation_2 delaunay
demo works correctly

--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://lists-sop.inria.fr/wws/info/cgal-discuss
Reply | Threaded
Open this post in threaded view
|

Re: Opengl with cgal 3.3.1 on Mac OS X Leopard

frank.vanmeurs
In reply to this post by scpeters
I just fixed the OpenGL issue myself in the same way. For completeness sake,
the S70-OPENGL file should look like this:

===SNIP===
# OPEN GL

DESCRIPTION = for Unix
PROVIDES = OPENGL
CXXFLAGS =
LDFLAGS = -dylib_file \
/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib:\
/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib
LIBS = GL GLU
REQUIRES =
INCOMPATIBLE = DOLLAR_WINDOWS_COMPILER
STDINCLDIRS = /usr/X11\*/include:/usr/openwin/include
INCLTHING = GL
STDLIBDIRS = /usr/X11\*/lib64:/usr/X11\*/lib:/usr/openwin/lib
LIBTHING = libGL.\*
COMPILETESTFLAGS =

# EOF
===/SNIP===

Frank
--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://lists-sop.inria.fr/wws/info/cgal-discuss