Linking error in compiling TAUCS libs

classic Classic list List threaded Threaded
16 messages Options
Reply | Threaded
Open this post in threaded view
|

Linking error in compiling TAUCS libs

kevin.kai.xu
Hi all, I need to recompile TAUCS (on Windows) but I encountered a problem:

I download taucs_full.tgz (TAUCS with precompiled external libraries) from CGAL download page.

I run the script build_taucs_win32_for_CGAL.bat to compile and install TAUCS in MS-DOS Prompt Shell.

The compilation stops at some "unresolved external symbol" linking error as follows:

........
        cl /nologo /MD /F64000000  /Febin\\win32_MD\\direct.exe  obj\\win32_MD\\
direct.obj  lib\\win32_MD\\libtaucs.lib  external\\lib\\win32\\liblapack.lib ext
ernal\\lib\\win32\\libf77blas.lib external\\lib\\win32\\libcblas.lib external\\l
ib\\win32\\libatlas.lib external\\lib\\win32_MD\\libmetis.lib external\\lib\\win
32_MD\\vcf2c.lib
libmetis.lib(fm.obj) : error LNK2001: unresolved external symbol __ftol2
libmetis.lib(balance.obj) : error LNK2001: unresolved external symbol __ftol2
libmetis.lib(match.obj) : error LNK2001: unresolved external symbol __ftol2
vcf2c.lib(lread.obj) : error LNK2001: unresolved external symbol __ftol2
libmetis.lib(ometis.obj) : error LNK2001: unresolved external symbol __ftol2
libmetis.lib(initpart.obj) : error LNK2001: unresolved external symbol __ftol2
libmetis.lib(pmetis.obj) : error LNK2001: unresolved external symbol __ftol2
libmetis.lib(sfm.obj) : error LNK2001: unresolved external symbol __ftol2
bin\\win32_MD\\direct.exe : fatal error LNK1120: 1 unresolved externals
NMAKE : fatal error U1077: 'cl' : return code '0x2'
Stop.

Where should 'ftol2' be defined? How do I resolve this problem?

Thank you in advance!

                              Kevin
--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://lists-sop.inria.fr/wws/info/cgal-discuss
Reply | Threaded
Open this post in threaded view
|

Re: Linking error in compiling TAUCS libs

Laurent Saboret
Hi Kevin,

A Google search of "error LNK2001: unresolved external symbol __ftol2" indicates
that:
If your source code includes a cast from double to long types, VC7 will generate
a call to _ftol2.

Indeed, build_taucs_win32_for_CGAL.bat expects to be called from a Visual C++
7.1 prompt shell (see CGAL-README.TXT).
Which version of VC++ are you using?

Best regards,
--
Laurent Saboret
INRIA Sophia-Antipolis


[hidden email] a écrit :

> Hi all, I need to recompile TAUCS (on Windows) but I encountered a problem:
>
> I download taucs_full.tgz (TAUCS with precompiled external libraries) from CGAL download page.
>
> I run the script build_taucs_win32_for_CGAL.bat to compile and install TAUCS in MS-DOS Prompt Shell.
>
> The compilation stops at some "unresolved external symbol" linking error as follows:
>
> ........
>         cl /nologo /MD /F64000000  /Febin\\win32_MD\\direct.exe  obj\\win32_MD\\
> direct.obj  lib\\win32_MD\\libtaucs.lib  external\\lib\\win32\\liblapack.lib ext
> ernal\\lib\\win32\\libf77blas.lib external\\lib\\win32\\libcblas.lib external\\l
> ib\\win32\\libatlas.lib external\\lib\\win32_MD\\libmetis.lib external\\lib\\win
> 32_MD\\vcf2c.lib
> libmetis.lib(fm.obj) : error LNK2001: unresolved external symbol __ftol2
> libmetis.lib(balance.obj) : error LNK2001: unresolved external symbol __ftol2
> libmetis.lib(match.obj) : error LNK2001: unresolved external symbol __ftol2
> vcf2c.lib(lread.obj) : error LNK2001: unresolved external symbol __ftol2
> libmetis.lib(ometis.obj) : error LNK2001: unresolved external symbol __ftol2
> libmetis.lib(initpart.obj) : error LNK2001: unresolved external symbol __ftol2
> libmetis.lib(pmetis.obj) : error LNK2001: unresolved external symbol __ftol2
> libmetis.lib(sfm.obj) : error LNK2001: unresolved external symbol __ftol2
> bin\\win32_MD\\direct.exe : fatal error LNK1120: 1 unresolved externals
> NMAKE : fatal error U1077: 'cl' : return code '0x2'
> Stop.
>
> Where should 'ftol2' be defined? How do I resolve this problem?
>
> Thank you in advance!
>
>                               Kevin



--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://lists-sop.inria.fr/wws/info/cgal-discuss
Reply | Threaded
Open this post in threaded view
|

Re: Linking error in compiling TAUCS libs

kevin.kai.xu
Hi Saboret,

I'm using VC8 (2005). Is it possible to resolve this problem with VC8.0?

Thank you very much.

                    Kevin

On 5/26/08, Laurent Saboret <[hidden email]> wrote:

> Hi Kevin,
>
> A Google search of "error LNK2001: unresolved external symbol __ftol2"
> indicates that:
> If your source code includes a cast from double to long types, VC7 will
> generate a call to _ftol2.
>
> Indeed, build_taucs_win32_for_CGAL.bat expects to be called from a Visual
> C++ 7.1 prompt shell (see CGAL-README.TXT).
> Which version of VC++ are you using?
>
> Best regards,
> --
> Laurent Saboret
> INRIA Sophia-Antipolis
>
--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://lists-sop.inria.fr/wws/info/cgal-discuss
Reply | Threaded
Open this post in threaded view
|

Re: Linking error in compiling TAUCS libs

Mahmood Naderan
In reply to this post by kevin.kai.xu
>I'm using VC8 (2005). Is it possible to resolve this problem with VC8.0?
Hi,
Can you send a picture of "project properties->linker->general" and "project properties->linker->input"?
-------------------
Mahmood Naderan
[hidden email]
 

 
----- Original Message ----
From: Kevin Xu <[hidden email]>
To: [hidden email]
Sent: Monday, May 26, 2008 12:35:24 PM
Subject: Re: [cgal-discuss] Linking error in compiling TAUCS libs

Hi Saboret,

I'm using VC8 (2005). Is it possible to resolve this problem with VC8.0?

Thank you very much.

                    Kevin

On 5/26/08, Laurent Saboret <[hidden email]> wrote:

> Hi Kevin,
>
> A Google search of "error LNK2001: unresolved external symbol __ftol2"
> indicates that:
> If your source code includes a cast from double to long types, VC7 will
> generate a call to _ftol2.
>
> Indeed, build_taucs_win32_for_CGAL.bat expects to be called from a Visual
> C++ 7.1 prompt shell (see CGAL-README.TXT).
> Which version of VC++ are you using?
>
> Best regards,
> --
> Laurent Saboret
> INRIA Sophia-Antipolis
>
--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://lists-sop.inria.fr/wws/info/cgal-discuss

Reply | Threaded
Open this post in threaded view
|

Re: Linking error in compiling TAUCS libs

kevin.kai.xu
Hi Naderan,

Thanks for your reply.

I recompiled TAUCS by running taucs_win32_for_CGAL.bat in prompt shell
and I didn't create any project. According to
taucs_win32_for_CGAL.bat, source codes of TAUCS will be compiled and
linked with the C++ compiler and linker of VC++8.0.
So I wonder whether TAUCS codes can be compiled correctly with
compiler of VC++8.0. If not, what should I do?

                     Kevin

On 5/26/08, Mahmood Naderan <[hidden email]> wrote:

>
>
> >I'm using VC8 (2005). Is it possible to resolve this problem with VC8.0?
> Hi,
> Can you send a picture of "project properties->linker->general" and "project
> properties->linker->input"?
> -------------------
> Mahmood Naderan
> m_naderan [AT} ce.sharif {DOT) edu
>
>
>
>
> ----- Original Message ----
> From: Kevin Xu <[hidden email]>
> To: [hidden email]
> Sent: Monday, May 26, 2008 12:35:24 PM
> Subject: Re: [cgal-discuss] Linking error in compiling TAUCS libs
>
> Hi Saboret,
>
> I'm using VC8 (2005). Is it possible to resolve this problem with VC8.0?
>
> Thank you very much.
>
>                     Kevin
>
> On 5/26/08, Laurent Saboret <[hidden email]> wrote:
> > Hi Kevin,
> >
> > A Google search of "error LNK2001: unresolved external symbol __ftol2"
> > indicates that:
> > If your source code includes a cast from double to long types, VC7 will
> > generate a call to _ftol2.
> >
> > Indeed, build_taucs_win32_for_CGAL.bat expects to be called from a Visual
> > C++ 7.1 prompt shell (see CGAL-README.TXT).
> > Which version of VC++ are you using?
> >
> > Best regards,
> > --
> > Laurent Saboret
> > INRIA Sophia-Antipolis
> >
> --
> You are currently subscribed to cgal-discuss.
> To unsubscribe or access the archives, go to
> https://lists-sop.inria.fr/wws/info/cgal-discuss
>
>
--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://lists-sop.inria.fr/wws/info/cgal-discuss
Reply | Threaded
Open this post in threaded view
|

Re: Linking error in compiling TAUCS libs

Laurent Saboret
In reply to this post by kevin.kai.xu
Hi Kevin,

My latest development version compiles happily with VC++ 2005 (32 and 64 bits).
Feel free to try it:
ftp://ftp-sop.inria.fr/geometrica/lsaboret/cgal/taucs_for_CGAL_3.4_beta1

Best regards,
--
Laurent Saboret
INRIA Sophia-Antipolis


Kevin Xu a écrit :

> Hi Saboret,
>
> I'm using VC8 (2005). Is it possible to resolve this problem with VC8.0?
>
> Thank you very much.
>
>                     Kevin
>
> On 5/26/08, Laurent Saboret <[hidden email]> wrote:
>> Hi Kevin,
>>
>> A Google search of "error LNK2001: unresolved external symbol __ftol2"
>> indicates that:
>> If your source code includes a cast from double to long types, VC7 will
>> generate a call to _ftol2.
>>
>> Indeed, build_taucs_win32_for_CGAL.bat expects to be called from a Visual
>> C++ 7.1 prompt shell (see CGAL-README.TXT).
>> Which version of VC++ are you using?
>>
>> Best regards,
>> --
>> Laurent Saboret
>> INRIA Sophia-Antipolis
>>



--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://lists-sop.inria.fr/wws/info/cgal-discuss
Reply | Threaded
Open this post in threaded view
|

Re: Linking error in compiling TAUCS libs

kevin.kai.xu
Hi Saboret,

Thank you for your help. I've downloaded the package taucs_full.zip
from your ftp site.

You provide two .bat files in taucs_full.zip, one for win 32bit and
one for 64bit. According to the CGAL-README.txt, I should run the
win64 one as my IDE is VC++2005. But I have a little confusion. My OS
is window xp (32 bit). Does it matter? My CPU is Intel(R) Core™2 Duo
Processor (may support 64 bit).

                              Kevin

On 5/26/08, Laurent Saboret <[hidden email]> wrote:

> Hi Kevin,
>
> My latest development version compiles happily with VC++ 2005 (32 and 64
> bits).
> Feel free to try it:
> ftp://ftp-sop.inria.fr/geometrica/lsaboret/cgal/taucs_for_CGAL_3.4_beta1
>
> Best regards,
> --
> Laurent Saboret
> INRIA Sophia-Antipolis
>
>
> Kevin Xu a écrit :
>
> > Hi Saboret,
> >
> > I'm using VC8 (2005). Is it possible to resolve this problem with VC8.0?
> >
> > Thank you very much.
> >
> >                    Kevin
> >
> > On 5/26/08, Laurent Saboret <[hidden email]> wrote:
> >
> > > Hi Kevin,
> > >
> > > A Google search of "error LNK2001: unresolved external symbol __ftol2"
> > > indicates that:
> > > If your source code includes a cast from double to long types, VC7 will
> > > generate a call to _ftol2.
> > >
> > > Indeed, build_taucs_win32_for_CGAL.bat expects to be called from a
> Visual
> > > C++ 7.1 prompt shell (see CGAL-README.TXT).
> > > Which version of VC++ are you using?
> > >
> > > Best regards,
> > > --
> > > Laurent Saboret
> > > INRIA Sophia-Antipolis
> > >
> > >
> >
>
>
>
> --
> You are currently subscribed to cgal-discuss.
> To unsubscribe or access the archives, go to
> https://lists-sop.inria.fr/wws/info/cgal-discuss
>

--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://lists-sop.inria.fr/wws/info/cgal-discuss
Reply | Threaded
Open this post in threaded view
|

Re: Linking error in compiling TAUCS libs

Laurent Saboret
Hi Kevin,

Windows XP 32 bits cannot run 64 bits applications. You should run
build_taucs_win32_for_CGAL.bat.

Best regards,
Laurent Saboret


Kevin Xu a écrit :

> Hi Saboret,
>
> Thank you for your help. I've downloaded the package taucs_full.zip
> from your ftp site.
>
> You provide two .bat files in taucs_full.zip, one for win 32bit and
> one for 64bit. According to the CGAL-README.txt, I should run the
> win64 one as my IDE is VC++2005. But I have a little confusion. My OS
> is window xp (32 bit). Does it matter? My CPU is Intel(R) Core™2 Duo
> Processor (may support 64 bit).
>
>                               Kevin
>
> On 5/26/08, Laurent Saboret <[hidden email]> wrote:
>> Hi Kevin,
>>
>> My latest development version compiles happily with VC++ 2005 (32 and 64
>> bits).
>> Feel free to try it:
>> ftp://ftp-sop.inria.fr/geometrica/lsaboret/cgal/taucs_for_CGAL_3.4_beta1
>>
>> Best regards,
>> --
>> Laurent Saboret
>> INRIA Sophia-Antipolis
>>
>>
>> Kevin Xu a écrit :
>>
>>> Hi Saboret,
>>>
>>> I'm using VC8 (2005). Is it possible to resolve this problem with VC8.0?
>>>
>>> Thank you very much.
>>>
>>>                    Kevin
>>>
>>> On 5/26/08, Laurent Saboret <[hidden email]> wrote:
>>>
>>>> Hi Kevin,
>>>>
>>>> A Google search of "error LNK2001: unresolved external symbol __ftol2"
>>>> indicates that:
>>>> If your source code includes a cast from double to long types, VC7 will
>>>> generate a call to _ftol2.
>>>>
>>>> Indeed, build_taucs_win32_for_CGAL.bat expects to be called from a
>> Visual
>>>> C++ 7.1 prompt shell (see CGAL-README.TXT).
>>>> Which version of VC++ are you using?
>>>>
>>>> Best regards,
>>>> --
>>>> Laurent Saboret
>>>> INRIA Sophia-Antipolis
>>>>


--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://lists-sop.inria.fr/wws/info/cgal-discuss
Reply | Threaded
Open this post in threaded view
|

CGAL 3.3.1 slow with VC++2008 ?

Johan Verbert
In reply to this post by kevin.kai.xu
Hello All,

I followed the instructions on
(http://acg.cs.tau.ac.il/cgal-at-tau/installing-cgal-and-related-programs-on-windows)
for using Cgal (3.3.1) with Visual Studio Express 2008 using boost
1.35.00.  And it seems to work fine.

However, if i compile and debug for example the straight skeleton demo
program, it seems a lot slower than it was previously.  It takes more
than two minutes to calculate the inner skeleton for the complex5
polygon (Vista, Core2Duo T7500@2.2ghz, 2gig ram).  If I compile and run
in release mode it doesnt even want to calculate any skeleton.
("Straight skeleton construction failed")

Does anyone have any explanation of what i am doing wrong, or a solution
perhaps ?

regards,
Johan

Disclaimer: http://www.kuleuven.be/cwis/email_disclaimer.htm

--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://lists-sop.inria.fr/wws/info/cgal-discuss
Reply | Threaded
Open this post in threaded view
|

Re: CGAL 3.3.1 slow with VC++2008 ?

Fernando Cacciola-3
Hi Johan,

> Hello All,
>
> I followed the instructions on
> (http://acg.cs.tau.ac.il/cgal-at-tau/installing-cgal-and-related-programs-on-windows)
> for using Cgal (3.3.1) with Visual Studio Express 2008 using boost
> 1.35.00.  And it seems to work fine.
>
> However, if i compile and debug for example the straight skeleton demo
> program, it seems a lot slower than it was previously.
"Previously" is what compiler, cgal version, etc?

> It takes more
> than two minutes to calculate the inner skeleton for the complex5
> polygon (Vista, Core2Duo T7500@2.2ghz, 2gig ram).
I suppose you are using checked iterators and the secure scl right?
Try defining _SECURE_SCL=0 and _HAS_ITERATOR_DEBUGGING=0, making sure to do the
same when building CGAL itself.

> If I compile and run
> in release mode it doesnt even want to calculate any skeleton.
> ("Straight skeleton construction failed")
>
*any* skeleton no matter which one, like within a simple rectangle?

HTH

Fernando Cacciola
GeometryFactory

--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://lists-sop.inria.fr/wws/info/cgal-discuss
Reply | Threaded
Open this post in threaded view
|

Re: CGAL 3.3.1 slow with VC++2008 ?

Johan Verbert
Hello Fernando,

The speed issue was compared to Cgal 3.3 compiled with the previous
version of Visual Studio Express (2007 i think).
And in release mode everything, even a simple rectangle failed.

_SECURE_SCL=0 was defined everywhere  but _HAS_ITERATOR_DEBUGGING=0 not

Adding _HAS_ITERATOR_DEBUGGING=0 when compiling CGAL and the demo fixed
everything!
I feel a little stupid now :)

thanks alot for the help!
Johan

Fernando Cacciola schreef:

> Hi Johan,
>
>> Hello All,
>>
>> I followed the instructions on
>> (http://acg.cs.tau.ac.il/cgal-at-tau/installing-cgal-and-related-programs-on-windows)
>>
>> for using Cgal (3.3.1) with Visual Studio Express 2008 using boost
>> 1.35.00.  And it seems to work fine.
>>
>> However, if i compile and debug for example the straight skeleton demo
>> program, it seems a lot slower than it was previously.
> "Previously" is what compiler, cgal version, etc?
>
>> It takes more
>> than two minutes to calculate the inner skeleton for the complex5
>> polygon (Vista, Core2Duo T7500@2.2ghz, 2gig ram).
> I suppose you are using checked iterators and the secure scl right?
> Try defining _SECURE_SCL=0 and _HAS_ITERATOR_DEBUGGING=0, making sure
> to do the same when building CGAL itself.
>
>> If I compile and run
>> in release mode it doesnt even want to calculate any skeleton.
>> ("Straight skeleton construction failed")
>>
> *any* skeleton no matter which one, like within a simple rectangle?
>
> HTH
>
> Fernando Cacciola
> GeometryFactory
>


Disclaimer: http://www.kuleuven.be/cwis/email_disclaimer.htm

--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://lists-sop.inria.fr/wws/info/cgal-discuss
Reply | Threaded
Open this post in threaded view
|

Re: CGAL 3.3.1 slow with VC++2008 ?

Ophir Setter
Hi,

I've tried to add _SECURE_SCL to one of my projects. The project works in Debug (with _SECURE_SCL=0 and without) and in Release without _SECURE_SCL.

When I try to run the project in Release with _SECURE_SCL I get the following errors:
From the command line I get:
CutAndPackExample.exe has encountered a problem and needs to close.  We are sorry for the inconvenience.

From the debugger I get:
"""
A buffer overrun has occurred in CutAndPackExample.exe which has corrupted the program's internal state. Press Break to debug the program or Continue to terminate the program.

For more details please see Help topic 'How to debug Buffer Overrun Issues'.
"""

What can I do? Do all the dependency libraries also have to have _SECURE_SCL=0 defined?

Ophir




On Wed, May 28, 2008 at 11:27 PM, Johan Verbert <[hidden email]> wrote:
Hello Fernando,

The speed issue was compared to Cgal 3.3 compiled with the previous version of Visual Studio Express (2007 i think).
And in release mode everything, even a simple rectangle failed.

_SECURE_SCL=0 was defined everywhere  but _HAS_ITERATOR_DEBUGGING=0 not

Adding _HAS_ITERATOR_DEBUGGING=0 when compiling CGAL and the demo fixed everything!
I feel a little stupid now :)

thanks alot for the help!
Johan

Fernando Cacciola schreef:

Hi Johan,

Hello All,

I followed the instructions on
(http://acg.cs.tau.ac.il/cgal-at-tau/installing-cgal-and-related-programs-on-windows)
for using Cgal (3.3.1) with Visual Studio Express 2008 using boost
1.35.00.  And it seems to work fine.

However, if i compile and debug for example the straight skeleton demo
program, it seems a lot slower than it was previously.
"Previously" is what compiler, cgal version, etc?

It takes more
than two minutes to calculate the inner skeleton for the complex5
polygon (Vista, Core2Duo T7500@2.2ghz, 2gig ram).
I suppose you are using checked iterators and the secure scl right?
Try defining _SECURE_SCL=0 and _HAS_ITERATOR_DEBUGGING=0, making sure to do the same when building CGAL itself.

If I compile and run
in release mode it doesnt even want to calculate any skeleton.
("Straight skeleton construction failed")

*any* skeleton no matter which one, like within a simple rectangle?

HTH

Fernando Cacciola
GeometryFactory



You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://lists-sop.inria.fr/wws/info/cgal-discuss

Reply | Threaded
Open this post in threaded view
|

Re: CGAL 3.3.1 slow with VC++2008 ?

Fernando Cacciola-3
Hi Ophir,

> Hi,
>
> [snip]
>
> What can I do? Do all the dependency libraries also have to have
> _SECURE_SCL=0 defined?
>
Yes.

_SECURE_SCL and _HAS_ITERATOR_DEBUGGING affect the definition of data structures
(to add checks), so it's all or nothing.

HTH

Fernando

--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://lists-sop.inria.fr/wws/info/cgal-discuss
Reply | Threaded
Open this post in threaded view
|

Re: CGAL 3.3.1 slow with VC++2008 ?

Ophir Setter
So what is the best thing to do?
I understand that the default CGAL build is _SECURE_SCL=0.

How come my project (that didn't define these macros) worked?
What about boost, GMP and MPFR? I didn't relate to this issue when compiling them to vc 9.0.
As I understood the default is _SECURE_SCL=1 and _HAS_ITERATOR_DEBUGGING=1. So how come my code works?

I guess that if it works - don't touch.

O


On Thu, May 29, 2008 at 5:28 PM, Fernando Cacciola <[hidden email]> wrote:
Hi Ophir,

Hi,

[snip]


What can I do? Do all the dependency libraries also have to have
_SECURE_SCL=0 defined?

Yes.

_SECURE_SCL and _HAS_ITERATOR_DEBUGGING affect the definition of data structures (to add checks), so it's all or nothing.

HTH

Fernando


--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://lists-sop.inria.fr/wws/info/cgal-discuss

Reply | Threaded
Open this post in threaded view
|

Re: CGAL 3.3.1 slow with VC++2008 ?

Fernando Cacciola-3
Hi Ophir,

> So what is the best thing to do?
> I understand that the default CGAL build is _SECURE_SCL=0.
>
Yes.

> How come my project (that didn't define these macros) worked?
> What about boost, GMP and MPFR?

GMP and MPFR are straight C code, so they are not affected by variations of the
SCL.

What boost pre-compiled libraries have you tested?

Just recently it was discussed that the default for boost in release builds
should be _SECURE_SCL=0.

>I didn't relate to this issue when compiling
> them to vc 9.0.
> As I understood the default is _SECURE_SCL=1

Yes

> and _HAS_ITERATOR_DEBUGGING=1.

In Debug builds only, of course.

Best

Fernando

--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://lists-sop.inria.fr/wws/info/cgal-discuss
Reply | Threaded
Open this post in threaded view
|

Re: CGAL 3.3.1 slow with VC++2008 ?

Ophir Setter


On Thu, May 29, 2008 at 7:10 PM, Fernando Cacciola <[hidden email]> wrote:
What boost pre-compiled libraries have you tested?

Just recently it was discussed that the default for boost in release builds should be _SECURE_SCL=0.

Ok. I had a little bit of a mess. I checked that all my libraries (except boost) are compiled with _SECURE_SCL=0 (one of the libraries I used was not compiled with this). My program still crashed when compiled with _SECURE_SCL=0. After I removed the link to boost program options it worked, so I guess that my boost is not compiled with _SECURE_SCL=0.

I used these instructions http://www.quantnet.org/forum/showthread.php?t=2221&page=2 to compile boost for vc 9.0.

Thanks Fernando for making a little bit of order in my mess. :)