Help compilation

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Help compilation

Olivier Devillers-2

I installed release 4.13
(Qt5, brew install --only-dependencies cgal, 4.13 from source)


I can compile the Triangulation_3 demo

But when compiling the Periodic_3_triangulation_3 
Cake tell me: 
NOTICE: This demo requires qcollectiongenerator, and will not be compiled.


Reply | Threaded
Open this post in threaded view
|

Re: Help compilation

Marc Glisse
On Wed, 9 Jan 2019, Olivier Devillers wrote:

> I installed release 4.13
> (Qt5, brew install --only-dependencies cgal, 4.13 from source)
>
>
> I can compile the Triangulation_3 demo
>
> But when compiling the Periodic_3_triangulation_3
> Cake tell me:
> NOTICE: This demo requires qcollectiongenerator, and will not be compiled.

Try to downgrade Qt to 5.11? IIUC with 5.12 we have to use qhelpgenerator
instead of qcollectiongenerator (I don't know if a symlink would work).

--
Marc Glisse

--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://sympa.inria.fr/sympa/info/cgal-discuss


Reply | Threaded
Open this post in threaded view
|

Re: Help compilation

Olivier Devillers-2
I solved my problem

Thank you

--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://sympa.inria.fr/sympa/info/cgal-discuss


Reply | Threaded
Open this post in threaded view
|

Re: Help compilation

Laurent Rineau (CGAL/GeometryFactory)
In reply to this post by Marc Glisse
On Wednesday, January 9, 2019 1:46:47 PM CET Marc Glisse wrote:

> On Wed, 9 Jan 2019, Olivier Devillers wrote:
> > I installed release 4.13
> > (Qt5, brew install --only-dependencies cgal, 4.13 from source)
> >
> >
> > I can compile the Triangulation_3 demo
> >
> > But when compiling the Periodic_3_triangulation_3
> > Cake tell me:
> > NOTICE: This demo requires qcollectiongenerator, and will not be compiled.
>
> Try to downgrade Qt to 5.11? IIUC with 5.12 we have to use qhelpgenerator
> instead of qcollectiongenerator (I don't know if a symlink would work).

I have adapted the two `CMakeLists.txt` to the new situation in Qt 5.12. Qt5
should have made the effort to keep a compatibility, by at least keeping a
CMake target alias!

Here is the pull-request:

  https://github.com/CGAL/cgal/pull/3587

--
Laurent Rineau, PhD
R&D Engineer at GeometryFactory           http://www.geometryfactory.com/
Release Manager of the CGAL Project       http://www.cgal.org/




--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://sympa.inria.fr/sympa/info/cgal-discuss