GLPK Library

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

GLPK Library

Chaman Singh Verma
Hello 

I am using CGAL-5.0 and trying to run /polyfit_example_without_input_planes 
executable.


My machine is running on Ubuntu and I installed libglpk from the Ubuntu repository.
The cmake understands the path.

But, while running I get the following message:

This test requires either GLPK or SCIP.

What should I do?

Thanks
Reply | Threaded
Open this post in threaded view
|

Re: GLPK Library

Joachim Reichel
Hi,

On 17.11.19 08:03, Chaman Singh Verma wrote:

> I am using CGAL-5.0 and trying to run /polyfit_example_without_input_planes 
> executable.
>
>
> My machine is running on Ubuntu and I installed libglpk from the Ubuntu repository.
> The cmake understands the path.
>
> But, while running I get the following message:
>
> This test requires either GLPK or SCIP.

are you sure that cmake detects the presence of GLPK and enables it? I have to
specify -DGLPK_LIBRARIES=/usr/lib/x86_64-linux-gnu/libglpk.so on Debian sid and
I would be surprised if Ubuntu was different in this respect. Also make sure to
have libglpk-dev installed. Then the example works fine for me.

If it still does not work, it might be helpful if you could state your Ubuntu
version and GPLK (package) versions.

  Joachim

--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://sympa.inria.fr/sympa/info/cgal-discuss


Reply | Threaded
Open this post in threaded view
|

Re: GLPK Library

Sebastien Loriot (GeometryFactory)
In reply to this post by Chaman Singh Verma
To use this package, you need one of those library.
So you need to install one of them and reconfigure the example with
cmake.

Best,

Sebastien.

On 11/17/19 8:03 AM, Chaman Singh Verma wrote:

> Hello
>
> I am using CGAL-5.0 and trying to run /polyfit_example_without_input_planes
> executable.
>
>
> My machine is running on Ubuntu and I installed libglpk from the Ubuntu
> repository.
> The cmake understands the path.
>
> But, while running I get the following message:
>
> This test requires either GLPK or SCIP.
>
> What should I do?
>
> Thanks

--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://sympa.inria.fr/sympa/info/cgal-discuss