Compile CGAL 4.13 Polyhedron_Demo

classic Classic list List threaded Threaded
14 messages Options
Reply | Threaded
Open this post in threaded view
|

Compile CGAL 4.13 Polyhedron_Demo

Andy Li
Hi, I am testing the point set classification function include manual extraction of the training set in CGAL 4.13. Unfortunately, after compiling the whole project, the Polyhedron_3.exe just can load the four implicit functions and four IO file functions. Though I put the .dlls into the same document of .exe and load the plugins from the program interface, they also do not work. What's wrong with my compile? Best regard Andy Li

Sent from the cgal-discuss mailing list archive at Nabble.com.
Reply | Threaded
Open this post in threaded view
|

Re: Compile CGAL 4.13 Polyhedron_Demo

Simon Giraudot-2

Hello,

Do you have all the needed dependencies? Boost IO Streams, Boost Serialization? (+ LASlib if you want to open LiDAR files)

Can you show the output of the cmake command?

Best regards,

-- 
Simon Giraudot, PhD
R&D Engineer
GeometryFactory - http://geometryfactory.com/
Le 24/10/2018 à 06:20, Andy Li a écrit :
Hi, I am testing the point set classification function include manual extraction of the training set in CGAL 4.13. Unfortunately, after compiling the whole project, the Polyhedron_3.exe just can load the four implicit functions and four IO file functions. Though I put the .dlls into the same document of .exe and load the plugins from the program interface, they also do not work. What's wrong with my compile? Best regard Andy Li

Sent from the cgal-discuss mailing list archive at Nabble.com.

Reply | Threaded
Open this post in threaded view
|

Re: Compile CGAL 4.13 Polyhedron_Demo

Andy Li
Except for Laslib and Metis, I think I take rest of the dependences. The
cmake command is as follow:

Boost version: 1.62.0
Found the following Boost libraries:
  thread
  system
  chrono
  date_time
  atomic
Boost include dirs: C:/boost_1_62_0/include
Boost libraries:  
optimized;C:/boost_1_62_0/lib64-msvc-12.0/boost_thread-vc120-mt-1_62.lib;debug;C:/boost_1_62_0/lib64-msvc-12.0/boost_thread-vc120-mt-gd-1_62.lib;optimized;C:/boost_1_62_0/lib64-msvc-12.0/boost_system-vc120-mt-1_62.lib;debug;C:/boost_1_62_0/lib64-msvc-12.0/boost_system-vc120-mt-gd-1_62.lib;optimized;C:/boost_1_62_0/lib64-msvc-12.0/boost_chrono-vc120-mt-1_62.lib;debug;C:/boost_1_62_0/lib64-msvc-12.0/boost_chrono-vc120-mt-gd-1_62.lib;optimized;C:/boost_1_62_0/lib64-msvc-12.0/boost_date_time-vc120-mt-1_62.lib;debug;C:/boost_1_62_0/lib64-msvc-12.0/boost_date_time-vc120-mt-gd-1_62.lib;optimized;C:/boost_1_62_0/lib64-msvc-12.0/boost_atomic-vc120-mt-1_62.lib;debug;C:/boost_1_62_0/lib64-msvc-12.0/boost_atomic-vc120-mt-gd-1_62.lib
Visual Leak Detector (VLD) is not found.
Multi-configuration CMake generator: cannot display flags
Targetting Visual Studio 12 2013 Win64
Target build enviroment supports auto-linking
Using VC12 compiler.
Generator uses intermediate configuration directory: $(Configuration)
Requested component: Qt5
Requested component: ImageIO
Requested component: MPFR
Requested component: GMP
Can not locate METIS include directory
Can not locate METIS library
Could NOT find METIS (missing: METIS_LIBRARIES METIS_INCLUDE_DIRS)
Found Intel TBB
Found Intel TBB
Boost version: 1.62.0
Found the following Boost libraries:
  thread
  system
  filesystem
  chrono
  date_time
  atomic

Boost version: 1.62.0
Found the following Boost libraries:
  serialization
  iostreams
  regex
Boost version: 1.62.0
Found the following Boost libraries:
  bzip2
  zlib
Found OpenCV 2.4.13
NOTICE : the LAS IO plugin needs LAS libraries and will not be compiled.
NOTICE : the Partition plugin needs METIS libraries and will not be
compiled.
Configuring done



--
Sent from: http://cgal-discuss.949826.n4.nabble.com/

--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://sympa.inria.fr/sympa/info/cgal-discuss


Reply | Threaded
Open this post in threaded view
|

Re: Compile CGAL 4.13 Polyhedron_Demo

Sebastien Loriot (GeometryFactory)
What kind of file are you trying to load?

Sebastien.

On 10/24/2018 07:29 AM, Andy Li wrote:

> Except for Laslib and Metis, I think I take rest of the dependences. The
> cmake command is as follow:
>
> Boost version: 1.62.0
> Found the following Boost libraries:
>    thread
>    system
>    chrono
>    date_time
>    atomic
> Boost include dirs: C:/boost_1_62_0/include
> Boost libraries:
> optimized;C:/boost_1_62_0/lib64-msvc-12.0/boost_thread-vc120-mt-1_62.lib;debug;C:/boost_1_62_0/lib64-msvc-12.0/boost_thread-vc120-mt-gd-1_62.lib;optimized;C:/boost_1_62_0/lib64-msvc-12.0/boost_system-vc120-mt-1_62.lib;debug;C:/boost_1_62_0/lib64-msvc-12.0/boost_system-vc120-mt-gd-1_62.lib;optimized;C:/boost_1_62_0/lib64-msvc-12.0/boost_chrono-vc120-mt-1_62.lib;debug;C:/boost_1_62_0/lib64-msvc-12.0/boost_chrono-vc120-mt-gd-1_62.lib;optimized;C:/boost_1_62_0/lib64-msvc-12.0/boost_date_time-vc120-mt-1_62.lib;debug;C:/boost_1_62_0/lib64-msvc-12.0/boost_date_time-vc120-mt-gd-1_62.lib;optimized;C:/boost_1_62_0/lib64-msvc-12.0/boost_atomic-vc120-mt-1_62.lib;debug;C:/boost_1_62_0/lib64-msvc-12.0/boost_atomic-vc120-mt-gd-1_62.lib
> Visual Leak Detector (VLD) is not found.
> Multi-configuration CMake generator: cannot display flags
> Targetting Visual Studio 12 2013 Win64
> Target build enviroment supports auto-linking
> Using VC12 compiler.
> Generator uses intermediate configuration directory: $(Configuration)
> Requested component: Qt5
> Requested component: ImageIO
> Requested component: MPFR
> Requested component: GMP
> Can not locate METIS include directory
> Can not locate METIS library
> Could NOT find METIS (missing: METIS_LIBRARIES METIS_INCLUDE_DIRS)
> Found Intel TBB
> Found Intel TBB
> Boost version: 1.62.0
> Found the following Boost libraries:
>    thread
>    system
>    filesystem
>    chrono
>    date_time
>    atomic
>
> Boost version: 1.62.0
> Found the following Boost libraries:
>    serialization
>    iostreams
>    regex
> Boost version: 1.62.0
> Found the following Boost libraries:
>    bzip2
>    zlib
> Found OpenCV 2.4.13
> NOTICE : the LAS IO plugin needs LAS libraries and will not be compiled.
> NOTICE : the Partition plugin needs METIS libraries and will not be
> compiled.
> Configuring done
>
>
>
> --
> Sent from: http://cgal-discuss.949826.n4.nabble.com/
>

--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://sympa.inria.fr/sympa/info/cgal-discuss


Reply | Threaded
Open this post in threaded view
|

Re: Compile CGAL 4.13 Polyhedron_Demo

Andy Li
Ply, txt or else. I could change the format from .las to .ply in my program
cause I use liblas for a long time. But, in the exe of Polyhedron demo, I
could not load the ply_plugin.dll and most of the plugins. Would it be
affected by the Metis and laslib?



--
Sent from: http://cgal-discuss.949826.n4.nabble.com/

--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://sympa.inria.fr/sympa/info/cgal-discuss


Reply | Threaded
Open this post in threaded view
|

Re: Compile CGAL 4.13 Polyhedron_Demo

Simon Giraudot-2
In reply to this post by Sebastien Loriot (GeometryFactory)
PLY or XYZ should work fine without Metis and LASlib (they are not related).

If I understand correctly, your plugins are correctly compiled (you do
have the dll of the plugins generated?) but not loaded. The demo is
supposed to load the plugins automatically when starting, you're not
supposed to need to move around any DLL or load them by hand.

Can you run the demo with the option --verbose so we see what happens?

Best,

--
Simon Giraudot, PhD
R&D Engineer
GeometryFactory - http://geometryfactory.com/

Le 24/10/2018 à 07:38, Andy Li a écrit :

> Ply, txt or else. I could change the format from .las to .ply in my program
> cause I use liblas for a long time. But, in the exe of Polyhedron demo, I
> could not load the ply_plugin.dll and most of the plugins. Would it be
> affected by the Metis and laslib?
>
>
>
> --
> Sent from: http://cgal-discuss.949826.n4.nabble.com/
>


--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://sympa.inria.fr/sympa/info/cgal-discuss


Reply | Threaded
Open this post in threaded view
|

Re: Compile CGAL 4.13 Polyhedron_Demo

Andy Li
When I use cmd to run the demo with the option "--verbose", it shows that
"###looking for ****.dll" and "###loading ****.dll". After that, the problem
is still here. The DLLs isn't loaded by the demo exe...


Sorry, I just could copy part of them, as follow:(The first line may show
that "Enable Scrift"?)


### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/Surface_mesh/Releas
e/mesh_simplification_sm_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/Surface_mesh/Releas
e/offset_meshing_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/Surface_mesh/Releas
e/parameterization_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/Surface_mesh/Releas
e/parameterization_sm_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/Surface_mesh/Releas
e/shortest_path_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/Surface_mesh/Releas
e/shortest_path_sm_plugin.dll "...
# Looking for plugins in directory
"C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugi
ns/Surface_mesh_deformation/Release"...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/Surface_mesh_deform
ation/Release/edit_polyhedron_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/Surface_mesh_deform
ation/Release/edit_sm_plugin.dll "...
Using context  4 . 2 GL
GL WARNING : (ShaderCompilerSource : OtherType)
 GLSL compile warning(s) for shader 1, "": WARNING: -1:65535: '#version' :
vers
ion number deprecated in OGL 3.0 forward compatible context driver



GL WARNING : (ShaderCompilerSource : OtherType)
 GLSL compile warning(s) for shader 2, "": WARNING: -1:65535: '#version' :
vers
ion number deprecated in OGL 3.0 forward compatible context driver



GL WARNING : (ShaderCompilerSource : OtherType)
 GLSL compile warning(s) for shader 4, "": WARNING: -1:65535: '#version' :
vers
ion number deprecated in OGL 3.0 forward compatible context driver



GL WARNING : (ShaderCompilerSource : OtherType)
 GLSL compile warning(s) for shader 5, "": WARNING: -1:65535: '#version' :
vers
ion number deprecated in OGL 3.0 forward compatible context driver



GL WARNING : (ShaderCompilerSource : OtherType)
 GLSL compile warning(s) for shader 7, "": WARNING: -1:65535: '#version' :
vers
ion number deprecated in OGL 3.0 forward compatible context driver
WARNING: 0:11: Only GLSL version > 110 allows postfix "F" or "f" for float



GL WARNING : (ShaderCompilerSource : OtherType)
 GLSL compile warning(s) for shader 8, "": WARNING: -1:65535: '#version' :
vers
ion number deprecated in OGL 3.0 forward compatible context driver
WARNING: 0:6: Only GLSL version > 110 allows postfix "F" or "f" for float
WARNING: 0:6: Only GLSL version > 110 allows postfix "F" or "f" for float
WARNING: 0:6: Only GLSL version > 110 allows postfix "F" or "f" for float
WARNING: 0:6: Only GLSL version > 110 allows postfix "F" or "f" for float
WARNING: 0:7: Only GLSL version > 110 allows postfix "F" or "f" for float
WARNING: 0:7: Only GLSL version > 110 allows postfix "F" or "f" for float
WARNING: 0:7: Only GLSL version > 110 allows postfix "F" or "f" for float
WARNING: 0:7: Only GLSL version > 110 allows postfix "F" or "f" for float
WARNING: 0:8: Only GLSL version > 110 allows postfix "F" or "f" for float
WARNING: 0:8: Only GLSL version > 110 allows postfix "F" or "f" for float
WARNING: 0:8: Only GLSL version > 110 allows postfix "F" or "f" for float
WARNING: 0:8: Only GLSL version > 110 allows postfix "F" or "f"

GL ERROR : (ShaderCompilerSource : ErrorType)
 GLSL compile failed for shader 10, "": WARNING: -1:65535: '#version' :
version
 number deprecated in OGL 3.0 forward compatible context driver
ERROR: 0:1: '' : syntax error: #version is mandatory and should be set
before an
y other token
ERROR: 0:2: '' : syntax error: #version is mandatory and should be set
before an
y other token
ERROR: 0:? : 'pre-mature EOF' : syntax error syntax error



QOpenGLShader::compile(Vertex): WARNING: -1:65535: '#version' :  version
number
deprecated in OGL 3.0 forward compatible context driver
ERROR: 0:1: '' : syntax error: #version is mandatory and should be set
before an
y other token
ERROR: 0:2: '' : syntax error: #version is mandatory and should be set
before an
y other token
ERROR: 0:? : 'pre-mature EOF' : syntax error syntax error


*** Problematic Vertex shader source code ***
#define lowp
#define mediump
#define highp
#line 1

    void setPosition();
    void main(void)
    {
        setPosition();
    }

    attribute highp   vec2      vertexCoordsArray;
    attribute highp   vec3      pmvMatrix1;
    attribute highp   vec3      pmvMatrix2;
    attribute highp   vec3      pmvMatrix3;
    void setPosition(void)
    {
        highp mat3 pmvMatrix = mat3(pmvMatrix1, pmvMatrix2, pmvMatrix3);
        vec3 transformedPos = pmvMatrix * vec3(vertexCoordsArray.xy, 1.0);
        gl_Position = vec4(transformedPos.xy, 0.0, transformedPos.z);
    }

***
Vertex shader for simpleShaderProg (MainVertexShader &
PositionOnlyVertexShader)
 failed to compile
GL ERROR : (ShaderCompilerSource : ErrorType)
 GLSL compile failed for shader 11, "": WARNING: -1:65535: '#version' :
version
 number deprecated in OGL 3.0 forward compatible context driver
ERROR: 0:1: '' : syntax error: #version is mandatory and should be set
before an
y other token
ERROR: 0:2: '' : syntax error: #version is mandatory and should be set
before an
y other token
ERROR: 0:? : 'pre-mature EOF' : syntax error syntax error



QOpenGLShader::compile(Fragment): WARNING: -1:65535: '#version' :  version
numbe
r deprecated in OGL 3.0 forward compatible context driver
ERROR: 0:1: '' : syntax error: #version is mandatory and should be set
before an
y other token
ERROR: 0:2: '' : syntax error: #version is mandatory and should be set
before an
y other token
ERROR: 0:? : 'pre-mature EOF' : syntax error syntax error


*** Problematic Fragment shader source code ***
#define lowp
#define mediump
#define highp
#line 1

    lowp vec4 srcPixel();
    void main()
    {
        gl_FragColor = srcPixel();
    }

    lowp vec4 srcPixel()
    {
        return vec4(0.98, 0.06, 0.75, 1.0);
    }

***
Fragment shader for simpleShaderProg (MainFragmentShader &
ShockingPinkSrcFragme
ntShader) failed to compile
GL ERROR : (ShaderCompilerSource : ErrorType)
 GLSL link failed for program 12, "": Attached vertex shader is not
compiled.


GL ERROR : (ShaderCompilerSource : ErrorType)
 GLSL link failed: Attached vertex shader is not compiled.


QOpenGLShader::link: Attached vertex shader is not compiled.

Errors linking simple shader: Attached vertex shader is not compiled.

GL ERROR : (ShaderCompilerSource : ErrorType)
 GLSL compile failed for shader 13, "": WARNING: -1:65535: '#version' :
version
 number deprecated in OGL 3.0 forward compatible context driver
ERROR: 0:1: '' : syntax error: #version is mandatory and should be set
before an
y other token
ERROR: 0:2: '' : syntax error: #version is mandatory and should be set
before an
y other token
ERROR: 0:? : 'pre-mature EOF' : syntax error syntax error



QOpenGLShader::compile(Vertex): WARNING: -1:65535: '#version' :  version
number
deprecated in OGL 3.0 forward compatible context driver
ERROR: 0:1: '' : syntax error: #version is mandatory and should be set
before an
y other token
ERROR: 0:2: '' : syntax error: #version is mandatory and should be set
before an
y other token
ERROR: 0:? : 'pre-mature EOF' : syntax error syntax error


*** Problematic Vertex shader source code ***
#define lowp
#define mediump
#define highp
#line 1

    attribute highp   vec2      textureCoordArray;
    varying   highp   vec2      textureCoords;
    void setPosition();
    void main(void)
    {
        setPosition();
        textureCoords = textureCoordArray;
    }

    attribute highp   vec4      vertexCoordsArray;
    void setPosition(void)
    {
        gl_Position = vertexCoordsArray;
    }

***
Vertex shader for blitShaderProg (MainWithTexCoordsVertexShader &
UntransformedP
ositionVertexShader) failed to compile
GL ERROR : (ShaderCompilerSource : ErrorType)
 GLSL compile failed for shader 14, "": WARNING: -1:65535: '#version' :
version
 number deprecated in OGL 3.0 forward compatible context driver
ERROR: 0:1: '' : syntax error: #version is mandatory and should be set
before an
y other token
ERROR: 0:2: '' : syntax error: #version is mandatory and should be set
before an
y other token
ERROR: 0:? : 'pre-mature EOF' : syntax error syntax error



QOpenGLShader::compile(Fragment): WARNING: -1:65535: '#version' :  version
numbe
r deprecated in OGL 3.0 forward compatible context driver
ERROR: 0:1: '' : syntax error: #version is mandatory and should be set
before an
y other token
ERROR: 0:2: '' : syntax error: #version is mandatory and should be set
before an
y other token
ERROR: 0:? : 'pre-mature EOF' : syntax error syntax error


*** Problematic Fragment shader source code ***
#define lowp
#define mediump
#define highp
#line 1

    lowp vec4 srcPixel();
    void main()
    {
        gl_FragColor = srcPixel();
    }

    varying   highp   vec2      textureCoords;
    uniform           sampler2D imageTexture;
    lowp vec4 srcPixel()
    {
return texture2D(imageTexture, textureCoords);
}

***
Fragment shader for blitShaderProg (MainFragmentShader &
ImageSrcFragmentShader)
 failed to compile
GL ERROR : (ShaderCompilerSource : ErrorType)
 GLSL link failed for program 15, "": Attached fragment shader is not
compiled.


GL ERROR : (ShaderCompilerSource : ErrorType)
 GLSL link failed: Attached fragment shader is not compiled.


QOpenGLShader::link: Attached fragment shader is not compiled.

Errors linking blit shader: Attached fragment shader is not compiled.

GL WARNING : (ShaderCompilerSource : OtherType)
 GLSL compile warning(s) for shader 16, "": WARNING: -1:65535: '#version' :
ver
sion number deprecated in OGL 3.0 forward compatible context driver



GL WARNING : (ShaderCompilerSource : OtherType)
 GLSL compile warning(s) for shader 17, "": WARNING: -1:65535: '#version' :
ver
sion number deprecated in OGL 3.0 forward compatible context driver



Execution of script ":/cgal/Polyhedron_3/javascript/lib.js"
Duplicate Filter:  "camera_positions_plugin"
This filter will not be available.
Duplicate Filter:  "polylines_io_plugin"
This filter will not be available.
Duplicate Filter:  "camera_positions_plugin"
This filter will not be available.
Duplicate Filter:  "polylines_io_plugin"
This filter will not be available.
Duplicate Filter:  "camera_positions_plugin"
This filter will not be available.
Duplicate Filter:  "polylines_io_plugin"
This filter will not be available.
GL WARNING : (ShaderCompilerSource : OtherType)
 GLSL compile warning(s) for shader 23, "": WARNING: -1:65535: '#version' :
ver
sion number deprecated in OGL 3.0 forward compatible context driver



GL WARNING : (ShaderCompilerSource : OtherType)
 GLSL compile warning(s) for shader 24, "": WARNING: -1:65535: '#version' :
ver
sion number deprecated in OGL 3.0 forward compatible context driver




--
Sent from: http://cgal-discuss.949826.n4.nabble.com/

--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://sympa.inria.fr/sympa/info/cgal-discuss


Reply | Threaded
Open this post in threaded view
|

Re: Compile CGAL 4.13 Polyhedron_Demo

Andy Li
In reply to this post by Simon Giraudot-2
The former part is shown as follow.

Enable scripts.
# Looking for plugins in directory
"C:/dev/CGAL-4.13/demo/Polyhedron/build/Relea
se"...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/affine_transform_pl
ugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/affine_transform_sm
_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/alpha_shape_plugin.
dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/basic_generator_plu
gin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/c3t3_io_plugin.dll
"...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/c3t3_rib_exporter_p
lugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/camera_positions_pl
ugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/classification_plug
in.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/clip_polyhedron_plu
gin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/clipping_box_plugin
.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/convex_hull_plugin.
dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/corefinement_plugin
.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/create_bbox_mesh_pl
ugin.dll "...
### Loading " C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/cut_plugin.dll
"...

### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/degenerated_faces_p
oly_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/degenerated_faces_s
m_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/detect_sharp_edges_
plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/detect_sharp_edges_
sm_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/display_property_pl
ugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/distance_plugin.dll
 "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/distance_sm_plugin.
dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/edit_box_plugin.dll
 "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/edit_polyhedron_plu
gin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/edit_sm_plugin.dll
"...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/extrude_poly_plugin
.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/extrude_sm_plugin.d
ll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/fairing_plugin.dll
"...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/fairing_sm_plugin.d
ll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/features_detection_
plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/gocad_plugin.dll ".
..
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/hole_filling_plugin
.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/hole_filling_polyli
ne_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/hole_filling_sm_plu
gin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/inside_out_plugin.d
ll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/io_image_plugin.dll
 "...
    + Loading Function "classification_plugin.dll"...
    + Loading Function "p_klein_function_plugin.dll"...
    + Loading Function "p_sphere_function_plugin.dll"...
    + Loading Function "p_tanglecube_function_plugin.dll"...
    + Loading Function "ply_plugin.dll"...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/io_implicit_functio
n_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/isotropic_remeshing
_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/isotropic_remeshing
_sm_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/jet_fitting_plugin.
dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/join_and_split_poly
hedra_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/join_and_split_sm_p
lugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/kernel_plugin.dll "
...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/mean_curvature_flow
_skeleton_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/mean_curvature_flow
_skeleton_sm_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/merge_point_sets_pl
ugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/mesh_2_plugin.dll "
...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/mesh_3_optimization
_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/mesh_3_plugin.dll "
...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/mesh_plane_detectio
n_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/mesh_segmentation_p
lugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/mesh_simplification
_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/mesh_simplification
_sm_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/nef_io_plugin.dll "
...
### Loading " C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/nef_plugin.dll
"...

### Loading " C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/off_plugin.dll
"...

### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/off_to_nef_plugin.d
ll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/offset_meshing_plug
in.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/orient_soup_plugin.
dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/parameterization_pl
ugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/parameterization_sm
_plugin.dll "...
### Loading " C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/pca_plugin.dll
"...

### Loading " C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/ply_plugin.dll
"...

### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/point_inside_polyhe
dron_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/point_set_average_s
pacing_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/point_set_bilateral
_smoothing_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/point_set_from_vert
ices_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/point_set_interfere
nce_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/point_set_normal_es
timation_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/point_set_outliers_
removal_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/point_set_selection
_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/point_set_shape_det
ection_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/point_set_simplific
ation_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/point_set_smoothing
_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/point_set_to_mesh_d
istance_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/point_set_upsamplin
g_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/point_set_wlop_plug
in.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/polyhedron_slicer_p
lugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/polyhedron_stitchin
g_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/polylines_io_plugin
.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/random_perturbation
_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/repair_polyhedron_p
lugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/selection_io_plugin
.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/selection_io_sm_plu
gin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/selection_plugin.dl
l "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/selection_sm_plugin
.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/self_intersection_p
lugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/self_intersection_s
m_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/shortest_path_plugi
n.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/shortest_path_sm_pl
ugin.dll "...
### Loading " C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/stl_plugin.dll
"...

### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/subdivision_methods
_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/surf_io_plugin.dll
"...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/surface_intersectio
n_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/surface_intersectio
n_sm_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/surface_mesh_io_plu
gin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/surface_mesh_to_pol
yhedron_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/surface_reconstruct
ion_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/triangulate_facets_
plugin.dll "...
### Loading " C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/vtk_plugin.dll
"...

### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Release/vtk_sm_plugin.dll "
...
# Looking for plugins in directory
"C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugi
ns"...
# Looking for plugins in directory
"C:/dev/CGAL-4.13/demo/Polyhedron/build/Relea
se"...
# Looking for plugins in directory
"C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugi
ns/AABB_tree/Release"...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/AABB_tree/Release/c
ut_plugin.dll "...
# Looking for plugins in directory
"C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugi
ns/Camera_position/Release"...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/Camera_position/Rel
ease/camera_positions_plugin.dll "...
# Looking for plugins in directory
"C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugi
ns/Classification/Release"...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/Classification/Rele
ase/classification_plugin.dll "...
# Looking for plugins in directory
"C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugi
ns/Convex_decomposition/Release"...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/Convex_decompositio
n/Release/nef_plugin.dll "...
# Looking for plugins in directory
"C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugi
ns/Convex_hull/Release"...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/Convex_hull/Release
/convex_hull_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/Convex_hull/Release
/kernel_plugin.dll "...
# Looking for plugins in directory
"C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugi
ns/Display/Release"...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/Display/Release/dis
play_property_plugin.dll "...
# Looking for plugins in directory
"C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugi
ns/IO/Release"...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/IO/Release/gocad_pl
ugin.dll "...
    + Loading Function "classification_plugin.dll"...
    + Loading Function "p_klein_function_plugin.dll"...
    + Loading Function "p_sphere_function_plugin.dll"...
    + Loading Function "p_tanglecube_function_plugin.dll"...
    + Loading Function "ply_plugin.dll"...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/IO/Release/io_impli
cit_function_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/IO/Release/nef_io_p
lugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/IO/Release/off_plug
in.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/IO/Release/off_to_n
ef_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/IO/Release/ply_plug
in.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/IO/Release/polyline
s_io_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/IO/Release/selectio
n_io_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/IO/Release/selectio
n_io_sm_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/IO/Release/stl_plug
in.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/IO/Release/surf_io_
plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/IO/Release/surface_
mesh_io_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/IO/Release/vtk_plug
in.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/IO/Release/vtk_sm_p
lugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/IO/Release/xyz_plug
in.dll "...
# Looking for plugins in directory
"C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugi
ns/Mesh_2/Release"...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/Mesh_2/Release/mesh
_2_plugin.dll "...
# Looking for plugins in directory
"C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugi
ns/Mesh_3/Release"...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/Mesh_3/Release/c3t3
_io_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/Mesh_3/Release/c3t3
_rib_exporter_plugin.dll "...
### Loading "
C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/Mesh_3/Release/io_i
mage_plugin.dll "...



--
Sent from: http://cgal-discuss.949826.n4.nabble.com/

--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://sympa.inria.fr/sympa/info/cgal-discuss


Reply | Threaded
Open this post in threaded view
|

Re: Compile CGAL 4.13 Polyhedron_Demo

Sebastien Loriot (GeometryFactory)
In reply to this post by Andy Li
To check whether it is an openGL related issue, could you check the
precompiled demos available at:
https://www.cgal.org/demo/4.13/polyhedron_3.zip
You will have to extract the following dlls in the same folder
as the Polyhedron_3.exe from the zip:
https://www.cgal.org/demo/4.13/CGAL-demoDLLs.zip

Best,

Sebastien.

On 10/24/2018 09:00 AM, Andy Li wrote:

> When I use cmd to run the demo with the option "--verbose", it shows that
> "###looking for ****.dll" and "###loading ****.dll". After that, the problem
> is still here. The DLLs isn't loaded by the demo exe...
>
>
> Sorry, I just could copy part of them, as follow:(The first line may show
> that "Enable Scrift"?)
>
>
> ### Loading "
> C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/Surface_mesh/Releas
> e/mesh_simplification_sm_plugin.dll "...
> ### Loading "
> C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/Surface_mesh/Releas
> e/offset_meshing_plugin.dll "...
> ### Loading "
> C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/Surface_mesh/Releas
> e/parameterization_plugin.dll "...
> ### Loading "
> C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/Surface_mesh/Releas
> e/parameterization_sm_plugin.dll "...
> ### Loading "
> C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/Surface_mesh/Releas
> e/shortest_path_plugin.dll "...
> ### Loading "
> C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/Surface_mesh/Releas
> e/shortest_path_sm_plugin.dll "...
> # Looking for plugins in directory
> "C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugi
> ns/Surface_mesh_deformation/Release"...
> ### Loading "
> C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/Surface_mesh_deform
> ation/Release/edit_polyhedron_plugin.dll "...
> ### Loading "
> C:/dev/CGAL-4.13/demo/Polyhedron/build/Plugins/Surface_mesh_deform
> ation/Release/edit_sm_plugin.dll "...
> Using context  4 . 2 GL
> GL WARNING : (ShaderCompilerSource : OtherType)
>   GLSL compile warning(s) for shader 1, "": WARNING: -1:65535: '#version' :
> vers
> ion number deprecated in OGL 3.0 forward compatible context driver
>
>
>
> GL WARNING : (ShaderCompilerSource : OtherType)
>   GLSL compile warning(s) for shader 2, "": WARNING: -1:65535: '#version' :
> vers
> ion number deprecated in OGL 3.0 forward compatible context driver
>
>
>
> GL WARNING : (ShaderCompilerSource : OtherType)
>   GLSL compile warning(s) for shader 4, "": WARNING: -1:65535: '#version' :
> vers
> ion number deprecated in OGL 3.0 forward compatible context driver
>
>
>
> GL WARNING : (ShaderCompilerSource : OtherType)
>   GLSL compile warning(s) for shader 5, "": WARNING: -1:65535: '#version' :
> vers
> ion number deprecated in OGL 3.0 forward compatible context driver
>
>
>
> GL WARNING : (ShaderCompilerSource : OtherType)
>   GLSL compile warning(s) for shader 7, "": WARNING: -1:65535: '#version' :
> vers
> ion number deprecated in OGL 3.0 forward compatible context driver
> WARNING: 0:11: Only GLSL version > 110 allows postfix "F" or "f" for float
>
>
>
> GL WARNING : (ShaderCompilerSource : OtherType)
>   GLSL compile warning(s) for shader 8, "": WARNING: -1:65535: '#version' :
> vers
> ion number deprecated in OGL 3.0 forward compatible context driver
> WARNING: 0:6: Only GLSL version > 110 allows postfix "F" or "f" for float
> WARNING: 0:6: Only GLSL version > 110 allows postfix "F" or "f" for float
> WARNING: 0:6: Only GLSL version > 110 allows postfix "F" or "f" for float
> WARNING: 0:6: Only GLSL version > 110 allows postfix "F" or "f" for float
> WARNING: 0:7: Only GLSL version > 110 allows postfix "F" or "f" for float
> WARNING: 0:7: Only GLSL version > 110 allows postfix "F" or "f" for float
> WARNING: 0:7: Only GLSL version > 110 allows postfix "F" or "f" for float
> WARNING: 0:7: Only GLSL version > 110 allows postfix "F" or "f" for float
> WARNING: 0:8: Only GLSL version > 110 allows postfix "F" or "f" for float
> WARNING: 0:8: Only GLSL version > 110 allows postfix "F" or "f" for float
> WARNING: 0:8: Only GLSL version > 110 allows postfix "F" or "f" for float
> WARNING: 0:8: Only GLSL version > 110 allows postfix "F" or "f"
>
> GL ERROR : (ShaderCompilerSource : ErrorType)
>   GLSL compile failed for shader 10, "": WARNING: -1:65535: '#version' :
> version
>   number deprecated in OGL 3.0 forward compatible context driver
> ERROR: 0:1: '' : syntax error: #version is mandatory and should be set
> before an
> y other token
> ERROR: 0:2: '' : syntax error: #version is mandatory and should be set
> before an
> y other token
> ERROR: 0:? : 'pre-mature EOF' : syntax error syntax error
>
>
>
> QOpenGLShader::compile(Vertex): WARNING: -1:65535: '#version' :  version
> number
> deprecated in OGL 3.0 forward compatible context driver
> ERROR: 0:1: '' : syntax error: #version is mandatory and should be set
> before an
> y other token
> ERROR: 0:2: '' : syntax error: #version is mandatory and should be set
> before an
> y other token
> ERROR: 0:? : 'pre-mature EOF' : syntax error syntax error
>
>
> *** Problematic Vertex shader source code ***
> #define lowp
> #define mediump
> #define highp
> #line 1
>
>      void setPosition();
>      void main(void)
>      {
>          setPosition();
>      }
>
>      attribute highp   vec2      vertexCoordsArray;
>      attribute highp   vec3      pmvMatrix1;
>      attribute highp   vec3      pmvMatrix2;
>      attribute highp   vec3      pmvMatrix3;
>      void setPosition(void)
>      {
>          highp mat3 pmvMatrix = mat3(pmvMatrix1, pmvMatrix2, pmvMatrix3);
>          vec3 transformedPos = pmvMatrix * vec3(vertexCoordsArray.xy, 1.0);
>          gl_Position = vec4(transformedPos.xy, 0.0, transformedPos.z);
>      }
>
> ***
> Vertex shader for simpleShaderProg (MainVertexShader &
> PositionOnlyVertexShader)
>   failed to compile
> GL ERROR : (ShaderCompilerSource : ErrorType)
>   GLSL compile failed for shader 11, "": WARNING: -1:65535: '#version' :
> version
>   number deprecated in OGL 3.0 forward compatible context driver
> ERROR: 0:1: '' : syntax error: #version is mandatory and should be set
> before an
> y other token
> ERROR: 0:2: '' : syntax error: #version is mandatory and should be set
> before an
> y other token
> ERROR: 0:? : 'pre-mature EOF' : syntax error syntax error
>
>
>
> QOpenGLShader::compile(Fragment): WARNING: -1:65535: '#version' :  version
> numbe
> r deprecated in OGL 3.0 forward compatible context driver
> ERROR: 0:1: '' : syntax error: #version is mandatory and should be set
> before an
> y other token
> ERROR: 0:2: '' : syntax error: #version is mandatory and should be set
> before an
> y other token
> ERROR: 0:? : 'pre-mature EOF' : syntax error syntax error
>
>
> *** Problematic Fragment shader source code ***
> #define lowp
> #define mediump
> #define highp
> #line 1
>
>      lowp vec4 srcPixel();
>      void main()
>      {
>          gl_FragColor = srcPixel();
>      }
>
>      lowp vec4 srcPixel()
>      {
>          return vec4(0.98, 0.06, 0.75, 1.0);
>      }
>
> ***
> Fragment shader for simpleShaderProg (MainFragmentShader &
> ShockingPinkSrcFragme
> ntShader) failed to compile
> GL ERROR : (ShaderCompilerSource : ErrorType)
>   GLSL link failed for program 12, "": Attached vertex shader is not
> compiled.
>
>
> GL ERROR : (ShaderCompilerSource : ErrorType)
>   GLSL link failed: Attached vertex shader is not compiled.
>
>
> QOpenGLShader::link: Attached vertex shader is not compiled.
>
> Errors linking simple shader: Attached vertex shader is not compiled.
>
> GL ERROR : (ShaderCompilerSource : ErrorType)
>   GLSL compile failed for shader 13, "": WARNING: -1:65535: '#version' :
> version
>   number deprecated in OGL 3.0 forward compatible context driver
> ERROR: 0:1: '' : syntax error: #version is mandatory and should be set
> before an
> y other token
> ERROR: 0:2: '' : syntax error: #version is mandatory and should be set
> before an
> y other token
> ERROR: 0:? : 'pre-mature EOF' : syntax error syntax error
>
>
>
> QOpenGLShader::compile(Vertex): WARNING: -1:65535: '#version' :  version
> number
> deprecated in OGL 3.0 forward compatible context driver
> ERROR: 0:1: '' : syntax error: #version is mandatory and should be set
> before an
> y other token
> ERROR: 0:2: '' : syntax error: #version is mandatory and should be set
> before an
> y other token
> ERROR: 0:? : 'pre-mature EOF' : syntax error syntax error
>
>
> *** Problematic Vertex shader source code ***
> #define lowp
> #define mediump
> #define highp
> #line 1
>
>      attribute highp   vec2      textureCoordArray;
>      varying   highp   vec2      textureCoords;
>      void setPosition();
>      void main(void)
>      {
>          setPosition();
>          textureCoords = textureCoordArray;
>      }
>
>      attribute highp   vec4      vertexCoordsArray;
>      void setPosition(void)
>      {
>          gl_Position = vertexCoordsArray;
>      }
>
> ***
> Vertex shader for blitShaderProg (MainWithTexCoordsVertexShader &
> UntransformedP
> ositionVertexShader) failed to compile
> GL ERROR : (ShaderCompilerSource : ErrorType)
>   GLSL compile failed for shader 14, "": WARNING: -1:65535: '#version' :
> version
>   number deprecated in OGL 3.0 forward compatible context driver
> ERROR: 0:1: '' : syntax error: #version is mandatory and should be set
> before an
> y other token
> ERROR: 0:2: '' : syntax error: #version is mandatory and should be set
> before an
> y other token
> ERROR: 0:? : 'pre-mature EOF' : syntax error syntax error
>
>
>
> QOpenGLShader::compile(Fragment): WARNING: -1:65535: '#version' :  version
> numbe
> r deprecated in OGL 3.0 forward compatible context driver
> ERROR: 0:1: '' : syntax error: #version is mandatory and should be set
> before an
> y other token
> ERROR: 0:2: '' : syntax error: #version is mandatory and should be set
> before an
> y other token
> ERROR: 0:? : 'pre-mature EOF' : syntax error syntax error
>
>
> *** Problematic Fragment shader source code ***
> #define lowp
> #define mediump
> #define highp
> #line 1
>
>      lowp vec4 srcPixel();
>      void main()
>      {
>          gl_FragColor = srcPixel();
>      }
>
>      varying   highp   vec2      textureCoords;
>      uniform           sampler2D imageTexture;
>      lowp vec4 srcPixel()
>      {
> return texture2D(imageTexture, textureCoords);
> }
>
> ***
> Fragment shader for blitShaderProg (MainFragmentShader &
> ImageSrcFragmentShader)
>   failed to compile
> GL ERROR : (ShaderCompilerSource : ErrorType)
>   GLSL link failed for program 15, "": Attached fragment shader is not
> compiled.
>
>
> GL ERROR : (ShaderCompilerSource : ErrorType)
>   GLSL link failed: Attached fragment shader is not compiled.
>
>
> QOpenGLShader::link: Attached fragment shader is not compiled.
>
> Errors linking blit shader: Attached fragment shader is not compiled.
>
> GL WARNING : (ShaderCompilerSource : OtherType)
>   GLSL compile warning(s) for shader 16, "": WARNING: -1:65535: '#version' :
> ver
> sion number deprecated in OGL 3.0 forward compatible context driver
>
>
>
> GL WARNING : (ShaderCompilerSource : OtherType)
>   GLSL compile warning(s) for shader 17, "": WARNING: -1:65535: '#version' :
> ver
> sion number deprecated in OGL 3.0 forward compatible context driver
>
>
>
> Execution of script ":/cgal/Polyhedron_3/javascript/lib.js"
> Duplicate Filter:  "camera_positions_plugin"
> This filter will not be available.
> Duplicate Filter:  "polylines_io_plugin"
> This filter will not be available.
> Duplicate Filter:  "camera_positions_plugin"
> This filter will not be available.
> Duplicate Filter:  "polylines_io_plugin"
> This filter will not be available.
> Duplicate Filter:  "camera_positions_plugin"
> This filter will not be available.
> Duplicate Filter:  "polylines_io_plugin"
> This filter will not be available.
> GL WARNING : (ShaderCompilerSource : OtherType)
>   GLSL compile warning(s) for shader 23, "": WARNING: -1:65535: '#version' :
> ver
> sion number deprecated in OGL 3.0 forward compatible context driver
>
>
>
> GL WARNING : (ShaderCompilerSource : OtherType)
>   GLSL compile warning(s) for shader 24, "": WARNING: -1:65535: '#version' :
> ver
> sion number deprecated in OGL 3.0 forward compatible context driver
>
>
>
>
> --
> Sent from: http://cgal-discuss.949826.n4.nabble.com/
>

--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://sympa.inria.fr/sympa/info/cgal-discuss


Reply | Threaded
Open this post in threaded view
|

Re: Compile CGAL 4.13 Polyhedron_Demo

Andy Li
It's available for me!!! Every plugin from your links could be loaded and
used.

What's the problem with my program...



--
Sent from: http://cgal-discuss.949826.n4.nabble.com/

--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://sympa.inria.fr/sympa/info/cgal-discuss


Reply | Threaded
Open this post in threaded view
|

Re: Compile CGAL 4.13 Polyhedron_Demo

Laurent Rineau (CGAL/GeometryFactory)
In reply to this post by Andy Li
Execute the demo, and then launch the action Preferences in the Edit menu.
Search for the plugin named "ply_plugin". It should appear in green. If it is
not in green, then let the mouse on the name, and have a look at the tooltip
that will show the detailed error.

--
Laurent Rineau, PhD
R&D Engineer at GeometryFactory           http://www.geometryfactory.com/
Release Manager of the CGAL Project       http://www.cgal.org/




--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://sympa.inria.fr/sympa/info/cgal-discuss


Reply | Threaded
Open this post in threaded view
|

Re: Compile CGAL 4.13 Polyhedron_Demo

Andy Li
Thanks for you all help.

From the action Preferences, I could see some plugins which are in red lines
and do not work. The tip shows that "The specified module could not be
found." I have compiled whole the plugins DLL and they exist in the
documents. I snap a picture. Could you please tell me why?  Thanks!
<http://cgal-discuss.949826.n4.nabble.com/file/t376030/test.jpg>



--
Sent from: http://cgal-discuss.949826.n4.nabble.com/

--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://sympa.inria.fr/sympa/info/cgal-discuss


Reply | Threaded
Open this post in threaded view
|

Re: Compile CGAL 4.13 Polyhedron_Demo

Laurent Rineau (CGAL/GeometryFactory)
On Wednesday, October 24, 2018 10:01:23 AM CEST Andy Li wrote:
> Thanks for you all help.
>
> >From the action Preferences, I could see some plugins which are in red
> >lines
> and do not work. The tip shows that "The specified module could not be
> found." I have compiled whole the plugins DLL and they exist in the
> documents. I snap a picture. Could you please tell me why?  Thanks!
> <http://cgal-discuss.949826.n4.nabble.com/file/t376030/test.jpg>

The errors displayed by the dynamic linker of Windows are unfortunately almost
unusable. The message says that at least one DLL required by the plugin could
not be found. But it does not say which one! Try the tool depends.exe, shipped
with Visual Studio. It helps debug that king of issue. You can also download
depends.exe here:

  http://www.dependencywalker.com/

--
Laurent Rineau, PhD
R&D Engineer at GeometryFactory           http://www.geometryfactory.com/
Release Manager of the CGAL Project       http://www.cgal.org/




--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://sympa.inria.fr/sympa/info/cgal-discuss


Reply | Threaded
Open this post in threaded view
|

Re: Compile CGAL 4.13 Polyhedron_Demo

Laurent Rineau (CGAL/GeometryFactory)
On Wednesday, October 24, 2018 11:09:38 AM CEST Laurent Rineau (CGAL/
GeometryFactory) wrote:

> On Wednesday, October 24, 2018 10:01:23 AM CEST Andy Li wrote:
> > Thanks for you all help.
> >
> > >From the action Preferences, I could see some plugins which are in red
> > >lines
> >
> > and do not work. The tip shows that "The specified module could not be
> > found." I have compiled whole the plugins DLL and they exist in the
> > documents. I snap a picture. Could you please tell me why?  Thanks!
> > <http://cgal-discuss.949826.n4.nabble.com/file/t376030/test.jpg>
>
> The errors displayed by the dynamic linker of Windows are unfortunately
> almost unusable. The message says that at least one DLL required by the
> plugin could not be found. But it does not say which one! Try the tool
> depends.exe, shipped with Visual Studio. It helps debug that king of issue.
> You can also download depends.exe here:
>
>   http://www.dependencywalker.com/

As said a college of mines, who know Microsoft VS better than me:

"Or start the application in Visual Studio. It will then tell what dll is
missing."

That solution seems easier than using depends.exe.

--
Laurent Rineau, PhD
R&D Engineer at GeometryFactory           http://www.geometryfactory.com/
Release Manager of the CGAL Project       http://www.cgal.org/




--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://sympa.inria.fr/sympa/info/cgal-discuss