Building 4.11 demos using CMake on Windows

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Building 4.11 demos using CMake on Windows

Andrew Cunningham
Hi,
I am trying to build CGAL 4.11 demos using CMake and Visual Studio 2017 64-bit on Windows.
I have QT 5.7 installed.

I can generate nearly all the examples ( which of course require CGAL to build and run ), and some of the demos but CMake is not generating many of the demos with the following error message.

-- Configuring demo in demo/Polygon

Requested component: Qt5

Requested component: Core

Requested component: MPFR

Requested component: GMP

NOTICE: This demo requires CGAL, CGAL_Core, and Qt5, and will not be compiled.


What I don't understand is why is is complaining about CGAL(??) and Qt5 not being available when they are properly configured in CMake along with QGLViewer. CMake finds my QT installation correctly.


Thanks

Andrew




Reply | Threaded
Open this post in threaded view
|

Re: Building 4.11 demos using CMake on Windows

Sebastien Loriot (GeometryFactory)
The cmake script does the following:

if ( CGAL_FOUND AND CGAL_Qt5_FOUND AND Qt5_FOUND )

Maybe you did not build CGAL Qt5 library?

Sebastien.

On 04/03/2018 07:08 PM, Andrew Cunningham wrote:

> Hi,
> I am trying to build CGAL 4.11 demos using CMake and Visual Studio 2017
> 64-bit on Windows.
> I have QT 5.7 installed.
>
> I can generate nearly all the examples ( which of course require CGAL to
> build and run ), and some of the demos but CMake is not generating many
> of the demos with the following error message.
>
> -- Configuring demo in demo/Polygon
>
> Requested component: Qt5
>
> Requested component: Core
>
> Requested component: MPFR
>
> Requested component: GMP
>
> NOTICE: This demo requires CGAL, CGAL_Core, and Qt5, and will not be
> compiled.
>
>
> What I don't understand is why is is complaining about CGAL(??) and Qt5
> not being available when they are properly configured in CMake along
> with QGLViewer. CMake finds my QT installation correctly.
>
>
> Thanks
>
> Andrew
>
>
>
>

--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://sympa.inria.fr/sympa/info/cgal-discuss