Apollonius_graph_2 demo

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Apollonius_graph_2 demo

Christian Jung
Hey,

I am trying to install the current version of CGAL (4.13) on my home computer running Ubuntu 16.04.
The build process worked so far.

When trying to make the Apollonius_graph_2 demo and run it I get the GUI attached in this email. It does not work properly. I installed CGAL 4.6.3 on the computer of the institute where I work and I know that the output application should have more feautures. In the output attached in this email there are serveral buttons missing. Yet, drawing apollonius diagrams works.

Is it possible that a library is missing on my computer?

Best regards
Chris

Bildschirmfoto vom 2018-11-28 03-35-55.png (30K) Download Attachment
Bildschirmfoto vom 2018-11-28 03-38-23.png (56K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Apollonius_graph_2 demo

ujur007
I am not sure but you might be missing some of the flags to compile the examples. 

Which flags are you using to compile your source code?


Best Regards,
Ujjval Rathod.

On Tue, Nov 27, 2018 at 6:39 PM Christian Jung <[hidden email]> wrote:
Hey,

I am trying to install the current version of CGAL (4.13) on my home computer running Ubuntu 16.04.
The build process worked so far.

When trying to make the Apollonius_graph_2 demo and run it I get the GUI attached in this email. It does not work properly. I installed CGAL 4.6.3 on the computer of the institute where I work and I know that the output application should have more feautures. In the output attached in this email there are serveral buttons missing. Yet, drawing apollonius diagrams works.

Is it possible that a library is missing on my computer?

Best regards
Chris
Reply | Threaded
Open this post in threaded view
|

Re: Apollonius_graph_2 demo

Sebastien Loriot (GeometryFactory)
In reply to this post by Christian Jung
What happens when you do Edit -> Insert Random Points?
I don't think the demo is doing more that that or you
can load points from a file.

Sebastien.

On 11/28/18 3:38 AM, Christian Jung wrote:

> Hey,
>
> I am trying to install the current version of CGAL (4.13) on my home
> computer running Ubuntu 16.04.
> The build process worked so far.
>
> When trying to make the Apollonius_graph_2 demo and run it I get the GUI
> attached in this email. It does not work properly. I installed CGAL
> 4.6.3 on the computer of the institute where I work and I know that the
> output application should have more feautures. In the output attached in
> this email there are serveral buttons missing. Yet, drawing apollonius
> diagrams works.
>
> Is it possible that a library is missing on my computer?
>
> Best regards
> Chris

--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://sympa.inria.fr/sympa/info/cgal-discuss


Reply | Threaded
Open this post in threaded view
|

AW: [cgal-discuss] Apollonius_graph_2 demo

Christian Jung
Insert random points works just fine (see attachment).

See also the demo of Apollonius_graph_2 of CGAL version 4.6.3.

It might have something to do with Qt3 as demos using it were removed in CGAL 4.8 or so.

What still bothers me is the fact that in the new demo a) the save button won't work (if pressed nothing happens) and b) the demo only shows the apollonius diagram, not the apollonius graph.


Von: [hidden email] <[hidden email]> im Auftrag von Sebastien Loriot (GeometryFactory) <[hidden email]>
Gesendet: Donnerstag, 29. November 2018 11:34
An: [hidden email]
Betreff: Re: [cgal-discuss] Apollonius_graph_2 demo
 
What happens when you do Edit -> Insert Random Points?
I don't think the demo is doing more that that or you
can load points from a file.

Sebastien.

On 11/28/18 3:38 AM, Christian Jung wrote:
> Hey,
>
> I am trying to install the current version of CGAL (4.13) on my home
> computer running Ubuntu 16.04.
> The build process worked so far.
>
> When trying to make the Apollonius_graph_2 demo and run it I get the GUI
> attached in this email. It does not work properly. I installed CGAL
> 4.6.3 on the computer of the institute where I work and I know that the
> output application should have more feautures. In the output attached in
> this email there are serveral buttons missing. Yet, drawing apollonius
> diagrams works.
>
> Is it possible that a library is missing on my computer?
>
> Best regards
> Chris

--
You are currently subscribed to cgal-discuss.
To unsubscribe or access the archives, go to
https://sympa.inria.fr/sympa/info/cgal-discuss



Screenshot from 2018-11-29 14-54-45.png (28K) Download Attachment
Screenshot from 2018-11-29 14-56-01.png (216K) Download Attachment